您的位置:首页 > 股票资源 > 同花顺公式

同花顺这么牛的指标公式

2019-04-15 23:32:46   来源:股旁网   编辑:股旁网

m:=21;
n:=21;
DC:=INDEXC;
DC1:=3;
DV:=INDEXC;
var11:=ZIG(DC1,6)>REF(ZIG(DC1,6),1) AND REF(ZIG(DC1,6),1)<=REF(ZIG(DC1,6),2) AND REF(ZIG(DC1,6),2)<=REF(ZIG(DC1,6),3);
var12:=ZIG(DC1,6)=REF(ZIG(DC1,6),2) AND REF(ZIG(DC1,6),2)>=REF(ZIG(DC1,6),3);
var13:=ZIG(DC1,22)>REF(ZIG(DC1,22),1) AND REF(ZIG(DC1,22),1)<=REF(ZIG(DC1,22),2) AND REF(ZIG(DC1,22),2)<=REF(ZIG(DC1,22),3);
var14:=ZIG(DC1,22)=REF(ZIG(DC1,22),2) AND REF(ZIG(DC1,22),2)>=REF(ZIG(DC1,22),3);
var15:=ZIG(DC1,51)>REF(ZIG(DC1,51),1) AND REF(ZIG(DC1,51),1)<=REF(ZIG(DC1,51),2) AND REF(ZIG(DC1,51),2)<=REF(ZIG(DC1,51),3);
var16:=ZIG(DC1,51)=REF(ZIG(DC1,51),2) AND REF(ZIG(DC1,51),2)>=REF(ZIG(DC1,51),3);
var17:=ZIG(DC1,72)>REF(ZIG(DC1,72),1) AND REF(ZIG(DC1,72),1)<=REF(ZIG(DC1,72),2) AND REF(ZIG(DC1,72),2)<=REF(ZIG(DC1,72),3);
var18:=ZIG(DC1,72)=REF(ZIG(DC1,72),2) AND REF(ZIG(DC1,72),2)>=REF(ZIG(DC1,72),3);
买:=(var11+var13+var15+var17);
卖:=(var12+var14+var16+var18);
新价:DC,colorwhite;//
DRAWTEXT(买>0,DC*0.99,必进),colorred,;
DRAWTEXT(卖>0,DC*1.02,清仓),colorgreen,;
b:=TROUGHBARS(DC1,5,1)=0;
e:=PEAKBARS(DC1,5,1)=0;
DRAWICON(b,INDEXL,1),colorred;
DRAWICON(e,INDEXH,2);
DRAWNUMBER(e,INDEXC*0.98,TOSTRING(INDEXH,2));//画数字
DRAWNUMBER(b,INDEXC*0.98,TOSTRING(INDEXL,2));//画数字
突破:REF(EMA(DC,14),1),coloryellow;//
A1X:=(EMA(DC,10)-突破)/突破*100;
多方:=IF(A1X>=0,REF(EMA(DC,10),BARSLAST(CROSS(A1X,0))+1),DRAWNULL);
空方:=IF(A1X<0,REF(EMA(DC,10),BARSLAST(CROSS(0,A1X))+1),DRAWNULL);
STICKLINE(A1X>=0,多方,突破,0,0),COLOR000099;//柱线
STICKLINE(A1X<0,空方,突破,0,0),COLOR00CC66;//柱线
均价线:SUM(DC*DV,240)/SUM(DV,240),colormagenta;//
AA:=ZIG(DC1,5),coloryellow;
DIFF1:=-(EMA(AA,26) - EMA(AA,12));
DEA1:=-(EMA(DIFF1,9));
MACD1:=2*(DIFF1-DEA1);
//转向变盘建仓
X:=IF(MACD1<0 AND REF(MACD1,2)>REF(MACD1,1) AND MACD1>REF(MACD1,1),1,0);
DRAWTEXT(X,INDEXC*0.97,"建仓"),coloryellow;
//量价指标
VPT:=SUM(DV/EMA(DV,N)*(DC-REF(DC,1))/REF(DC,1),0);
MAVPT:=EMA(VPT,M);
//均价线金叉
DRAWICON(CROSS(新价,均价线) AND 新价>突破 AND CLOSE>MA(CLOSE,144),均价线,1);
DRAWICON(CROSS(突破,均价线),均价线,1);
//底部
B:=ZIG(DC1,50/5),colorred;
G:=MA(B,2),coloryellow;
D:=CROSS(B,G)*(-0.5),STICK,colormagenta,LINETHICK3;//
DRAWTEXT(D<0,INDEXC*0.95,"底部"),coloryellow;

同花顺这么牛的指标公式

 

郑重声明:股票之家所有内容和资源仅供参考学习,本站不保证其准确性、真实性、完整性、有效性、及时性、原创性,不对您构成任何投资建议,据此操作,风险自负,本站不承担任何责任。股市有风险,投资需谨慎。本站部分内容来源于网络,如侵犯了您的版权,请和站长联系删除。
股票之家,专注为中小股民提供炒股入门知识,股票入门基础知识,股票资讯,今日股市新闻,炒股经验等信息,股票之家—靠谱的股票学习和炒股交流网站!
版权所有:股票之家, www.sanhu.com   豫ICP备18015034号-1   广告合作QQ:258637100,邮箱:258637100#qq.com